« Torn Paper Edges | Main | Photoshop and ERROR -39 »

Comments

Karen

I'm searching for a photo shop,or other programs, where I can edit a photograph. I do have photo shop 2, but it won't do what I need it to do. I have a wedding picture of my daughters that needs touched up. Her mother in law had spilt a drink on her dress, & it left big spots, & stains all over her dress. Every family picture that she was in had stains on her dress. I tried cloning, & the effect brush, & colorize, & blur brush & they don't work. A friend of mine, said she used a tool called the patch tool. She did one picture for me & it looked as if nothing was ever spilt on her dress. do you know which photo shop that I can buy with this tool on it& where can I buy it at.

Please E-mail me at My e-mail address with ATTENTION: Karen, Photo stain remover
E-Mail : sweetL287@aol.com

Dennis Reso

What seems to work for me:
1. Create a mask for the dust off filter
(a) Open an image with a clear area (clear sky)
(b) Select quick mask mode
(c) Highlight/Select dust with a small soft brush, low flow
(c) Exit quick mask, Invert the selection.
You likely get a warning "selection not visible"

2. Save the mask in a file
(a) Using Select>Save Selection...
(b) Choose "New" document, name the channel "Dust"
(c) Image should be a black mask, with small soft dust spots
(c) Save and Close this new file ("Dust.psd").

3. Record an action which invokes the following JavaScript
(a) Use File>Scripts>Browse... to Load the script "dustOff.js"
(b) Contents of dustOff.js:
var doc = app.activeDocument;
var dust = app.open(new File("~/Desktop/Dust.psd"));

app.activeDocument = doc;
doc.selection.load(dust.channels.getByName("Dust"),
SelectionType.REPLACE,false);
doc.backgroundLayer.applyDustAndScratches(16,0);

dust.close(SaveOptions.DONOTSAVECHANGES);

4. Use File>Automate>Batch... to execute the Action.

A bit more complex scripting could probably use an already open
Dust file, and find it by name or by "previous" as needed.
This of course assumes you want to affect the "Background" layer.

Neil Croft

It can be done, but as Gethin Coles said, you can't really do it if the dust spot is on a fussy area of the picture.

This is how i did it, just creating a path the normal way didn't work.

So create a new action, now your recording,

1, select the rectangular marquee tool.
2. Set the selection, (just over the dust spot you are getting rid off, make sure the lines of the rectangle are inside the dust spot)
3. Right click the rectangle and select make path
4. Select the healong brush tool and alt click your source
5. In the path pallatte select stroke path (with the healing brush)

Stop Recording your action, and you can now automate a batch.

(Best to try with a few pictures in a batch first incase and detail gets under the spots etc)

Gethin Coles

I have used the healing brush with an action, but it only works where there are large fairly uniform areas (like cloud free skies). In your action you need to create a path and then stroke the path with the healing brush from a pre-defined pattern (in my case a clean area of sky). You create the path using glowing edges and then selecting the shadows and creating a working path from the selection.

matt coupe

Try area selection in quick mask for large areas then using Dust and scratchs experiment with the settings to reduce of rermove bulk D and S then return details using history brush. (matt coupe Getty Images)

The comments to this entry are closed.

Cool

  • Get a critique
  • Submit tutorial
  • Get Text Links
  • Show us your portfolio

sponsors